fechar

Aprender Excel

APRENDER EXCEL

DICAS E NOVIDADES SOBRE EXCEL

Como inserir zero à esquerda no Excel

por: Felipe Paranhos em Dicas, no dia 16/09 | 15:11 atualizado em 24/08 | 08:10

Com o objetivo de tornar uma planilha mais uniforme e esteticamente organizada, dispõe-se de uma maneira de padronizar a quantidade de dígitos das células que conterão valores. Assim, colocar-se-á, automaticamente, zeros a esquerda de valores menores do que o número de dígitos solicitado.

Temos dois métodos: Com a formatação de células e com a função =Text0(). Vamos ver os dois.

Formatando células

Começando pela formatação de células enviada pelo nosso leitor Jeferson Alfonsin; Veja que fácil:

Selecione as células a receberem o zero e clique com o botão direito. Vá então na opção "Formatar células"... Abrirá uma nova janela. Nela navegue até a guia "Número", depois opção "personalizado" e na caixa de texto "Tipo:" coloque quantos zeros quiser. No exemplo abaixo eu queria 5 zeros. Veja que depois de pronto, o primeiro grupo de números, que tinha 4 dígitos ficou com apenas 1 zerom já o grupo que tinha 2 números ficou com 3 zeros. 

Fácil, certo? Lembre-se que se você quiser quantidades de zeros diferentes para cada grupo é só fazer uma formatação personalizada para cada um deles. Veja como ficou e o passo a passo:

Método =Texto()

Para isto, poderemos utilizar a função =Texto(), a qual consiste em designar um formato de texto para o conteúdo da célula que for dele aplicado. Suponha, como exemplo, uma coluna contendo valores aleatórios e queira-se padronizá-las com quatro algarismos. Vejamos como proceder:

1 - Lance os valores no Excel e lembre-se de colocá-los com no máximo quatro algarismos, para depois podermos uniformizá-los.

2 - Na coluna ao lado que iremos padronizar os valores através da função; então, ao lado da primeira célula aplique a função =TEXTO(B2;'0000') referindo-se que o valor da célula B2 deve possuir quatro algarismos.

3 - Obtemos, assim, o resultado.

4 - Agora, expanda a função da primeira célula às demais, arrastando seu canto inferior direito e cobrindo as células que queira aplicar a função.

OBSERVAÇÃO: Veja que, como o número 632,5 continha quatro algarismo, porém, possuia vírgula (e não foi estabelecido nenhuma restrição para a mesma), o Excel arredondou o número automaticamente e o dispôs com quatro algarismos novamente, ou seja, com um zero à esquerda.

Trabalho concluído! Agora organize e padronize as suas planilhas! Além de bonitas, elas poderão ser mais valorizadas e bem vistas pelas outras pessoas, seu chefe, por exemplo.

Enfim, faça do Excel um grande aliado para sua vida!