fechar

Aprender Excel

APRENDER EXCEL

DICAS E NOVIDADES SOBRE EXCEL

Os erros mais comuns ao utilizar fórmulas no Excel

por: Jeferson Junior em Dicas, no dia 16/02 | 11:35 atualizado em 25/08 | 08:10

Quantas vezes você digitou aquela formula enorme no Excel e na hora de apertar o enter vem aquela mensagem de erro.

Aproveitando: Veja o que quer dizer as mensagens de erro e depois veja como resolver cada um dos tipos de erros.

Ai você tem que ficar procurando letra por letra para encontrar esse erro na fórmula no Excel, principalmente quando a fórmula é extensa e complexa. Ai vem uma lista com algumas dicas que vão te ajudar a não passar por isso mais uma vez.

Parênteses

Esse erro é clássico.
Verifique se todos os parênteses usados na fórmula têm um par correspondente. Quando você cria uma fórmula, o Excel exibe parênteses coloridos à medida que eles são inseridos. Visando facilitar essa questão, o Excel (em alguns casos), já fecha automaticamente os parênteses que ficaram abertos.

Outro erro cometido em relação aos parênteses está na criação de fórmulas no Excel. Assim como uma vírgula pode dar um sentido totalmente inverso a uma frase em Português, os parênteses colocados em lugares errados podem alterar totalmente o resultado de uma fórmula.
Por exemplo:

O resultado dessa fórmula: =A1*(B1+C1) será diferente da fórmula =A1*B1+(C1)

Digitação dos intervalos

Para fazer referência a um intervalo de células em uma fórmula, use dois-pontos (:), em vez de outros símbolos como um travessão (-), para indicar a primeira e a última células do intervalo.

Por exemplo: Insira =A1:A5 em vez de =A1-A5.
Em fórmulas, 'dois-pontos' não são usados como um operador matemático, mas um travessão (ou um sinal de subtração) sim.
Lembrando que:

'dois-pontos' representam DE -> ATÉ

Exemplo: =SOMA(A1:A5) -> Somar de A1 ATÉ A5

'ponto-vírgula' representam E

Exemplo: =SOMA(A1;A5) -> Somar A1 E A5

Acredite você ou não, esse erro é MUITO comum entre os usuários ao criar fórmulas no Excel

Argumentos

Isso geralmente acontece mais quando se está criando uma fórmula mais complexas. Para concluir uma fórmula com êxito, verifique se inseriu o número correto de argumentos necessários.

Exemplo:

=SE(A1B1;C1;D1)

Que argumento obrigatório faltou nessa função SE?

Resposta: Faltou o [teste_lógico], ou seja, SE A1 é maior, menor, igual, diferente, etc. do que B1

Correto: =SE(A1>B1;C1;D1)

Limite de funções

Ao aninhar outras funções nos argumentos de uma fórmula que usa uma função, verifique se manteve o limite de 64 níveis de funções aninhadas nessa fórmula.

Geralmente isso acontece quando ao invés de usar a função SOMA, por exemplo, usa-se:

=A3:A6+F10+C1+D5:D201+E1+F1+G1+H1+I5:K8+J1+K1+L1+M1:N3...

Referências

Se, em uma fórmula, você fizer referência a valores ou células contidos em outra planilha ou pasta de trabalho, e o nome dessa planilha ou pasta de trabalho contiver um caractere não alfabético, coloque o nome entre aspas simples (").

Exemplo

Forma errada: =SOMA(A1;[Pasta2]planilha-10!A1)

Forma correta: =SOMA(A1;"[Pasta2]planilha-10"!A1)

Formatação

Verifique se não incluiu formatos de número ao inserir números em uma fórmula. Nos argumentos de fórmulas, o cifrão ($) é usado para indicar referências absolutas, e a vírgula (,) é usada como um separador de argumentos.

Portanto, em vez de inserir $1,000 na fórmula, insira apenas o número 1000.