Tutoriais

Retornando valores listados através de código identificador no Excel

Sabe quando você coloca um código e do nada aparece nome do produto, preço, e tantas outras informações? Pois é isso que aprenderemos.

Por Maximiliano Meyer em 04/09/2015 às 15:43 - atualizado: 09/08/2017 08:10

Hoje vamos ensinar mais um truque sensacional que foi pedido por e-mail: como puxar valores definidos através de um código.

Funciona assim: Você está cadastrando o estoque da sua loja de smartphones. Na sua loja o item número 001 corresponde ao LG G4, o número 002 ao Apple iPhone 6, o 003 ao Sony Xperia Z3+ e assim por diante.

Com o truque que aprenderemos hoje, cada vez que você digitar 001 no local desejado, como na hora de preencher a nota fiscal, o Excel vai preencher o campo nome com “LG G4”, o campo preço com o valor informado e todas as outras infos que você quiser.

Para fazer isto vamos precisar da função =Procv que você confere aqui neste tutorial (seria interessante que você lesse antes de continuar a aula de hoje).

Vamos lá: Primeiro vamos criar a estrutura da nossa planilha. Algo bem simples. Apenas código e nome, assim como dei no exemplo no início desse texto. Logo ao lado vamos colocar o “banco de dados”, ou seja, o cadastro de produtos.

Retornando valores listados através de código identificador no Excel

Agora, vamos inserir a fórmula. Como já disse será utilizado o =Procv e a sua sintaxe é =Procv(valor_procurado; matriz_tabela; núm_indice_coluna; procurar_intervalo), onde:

  • valor_procurado: Aqui você indicará a referência da célula do que será buscado, no nosso caso será B7, a célula onde entraremos com o código;
  • matriz_tabela: Neste campo você irá referenciar o banco de dados onde cadastramos os produtos, no nosso exemplo é F7:G9 Note que obrigatoriamente deve conter tanto a coluna com o código, como o nome do produto (e outras opções caso houvesse: preços, fornecedor, número de série, etc.);
  • núm_indice_coluna: Esse item corresponde ao número da coluna da tabela, indicada no item matriz_tabela, o qual o Excel deve retornar conteúdo. Como no nosso caso é a segunda coluna, vamos inserir o valor 2;
  • procurar_intervalo: Aqui é opcional e funciona mais como um norte para o Excel. Neste item vamos dizer se queremos apenas o que for EXATAMENTE igual ou se pode ser um valor aproximado. Se você colocar FALSO ou 0, a função só encontrará o que for igual ao termo buscado, agora, se colocar VERDADEIRO ou 1, ele poderá retornar algo semelhante. Como queremos apenas o exato, vamos colocar 0.

A fórmula será inserida na célula onde deverá ser informado o valor da busca, no nosso caso em C7. A propósito, nossa fórmula ficou =Procv(B7;F7:G9;2;0)

Retornando valores listados através de código identificador no Excel

Será que já deu certo? Confira o gif abaixo para tirar as dúvidas =)

Retornando valores listados através de código identificador no Excel

Show hein? Agora é só usar alça de preenchimento para copiar e atualizar a fórmula para as demais células. Não esqueça que é necessário bloquear os valores de referência. Confira como fazer e porque isto é importante.

Mas e se quiséssemos mais campos, como preço, por exemplo? Simples, apenas colocaríamos o campo preço na busca e cadastraríamos o mesmo no nosso banco:

Retornando valores listados através de código identificador no Excel

A fórmula inserida em C7 para retornar o nome do aparelho permanecerá a mesma, e em E7 para retornar o preço precisará de pequenas alterações. Na verdade, apenas 1. Onde antes pedíamos para ser informado a coluna 2, agora queremos a coluna 3, pois é a coluna de preço. No fim ficará =Procv(B7;G7:I9;3;0)

Retornando valores listados através de código identificador no Excel

Agora que a fórmula está pronta, vamos deixar a coisa mais bonita e funcional. Primeiro vamos passar esse banco de dados para uma outra planilha, afinal, faz mais sentido que ele não esteja no mesmo lugar de onde retornará, certo?

Veja no print abaixo que criei uma segunda planilha e chamei de “Bando de dados”. Lá coloquei todos os dados, igualzinho como vimos antes. A diferença é que na fórmula =Procv teremos de informar ao Excel que os dados devem ser buscados em outro local. Para entender como fazer a referência, confira esse tutorial, está bem explicadinho.

Na prática nossa fórmula ficará =PROCV(B7;'Banco de dados'!$C$8:$D$10;2;0)

Retornando valores listados através de código identificador no Excel

Ótimo, só falta mais uma coisinha: Reparou que quando o campo de busca está vazio o Excel retorna o erro, #N/D ? Vamos consertar isso com a função =SeErro. Confira a aula que fizemos sobre a função, ela é bem simples. Na prática ficará =SEERRO(PROCV(B8;'Banco de dados'!$C$8:$D$10;2;0);"")

Confira o resultado: Na coluna “Aparelho” está com a =SeErro e na coluna “Preço” não está, por isso o erro.

Retornando valores listados através de código identificador no Excel

Estamos prontos. Veja o resultado final: 

Retornando valores listados através de código identificador no Excel

Legal? Em breve coloco uma planilha com este processo pronto e mais algumas funções bem bacanas para seu estoque, nota fiscal, etc.

Retornando valores listados através de código identificador no Excel

relacionados

Participe
do nosso grupo

recentes

compartilhe este post

  • ASSINE NOSSA NEWSLETTER

    As melhores publicações no
    seu e-mail

  • Preencha para confirmar