Artigos

Utilizando data como condição em uma fórmula no Excel

Veja como é simples utilizar uma data dentro de um cálculo que envolve condição.

Por Maximiliano Meyer em 23/10/2015 às 10:00 - atualizado: 15/06/2017 12:00

A aula de hoje vai resolver os problemas de muita gente, pois é um dos assuntos mais buscados no site: Como trabalhar com horas no Excel. E se você acompanha o site e acha que já viu algo do tipo por aqui, não está errado não, pois este não será o primeiro post sobre o tema aqui no Aprender Excel. Confira também nossa aula de como calcular intervalos de datas, dias úteis no periodo, etc. Se achar mais fácil, tem também o download de uma planilha que faz o cálculo entre quantidades de dias, meses e anos entre 2 datas informadas automaticamente. Confira a aula e baixe sua cópia aqui neste link.

Ahh, e já aproveite para clicar aqui e aprender a função =Hoje(). Trata-se de um recurso muito bacana para as suas planilhas.

A aula de hoje, no entanto, vem para esclarecer uma dúvida que chegou por e-mail: Como calcular algo com base em data, ou seja, colocar uma data como condição em uma fórmula.

Primeiro temos que esclarecer um conceito muito importante: Como o Excel interpreta datas. Funciona assim: O sistema de datas do Excel começa em 1 de janeiro de 1900 (01/01/1900). Esta data é o número 1 para o programa. Sim, se você digitar 1 no Excel e converter a célula para o formato data, será exibido 01/01/1900, se você digitar 2, irá informar 02/01/1900 e se eu colocar 42300 iremos ter a data do dia em que escrevo esta aula, 23/10/2015.

Utilizando data como condição em uma fórmula no Excel

Bom, agora que já sabemos isso já podemos começar a utilizar datas nas nossas fórmulas e condicionais. Veja o seguinte exemplo:

Utilizando data como condição em uma fórmula no Excel

Digamos que eu quero saber a soma dos balanços a partir do dia 20 de outubro. Para isso usarei a fórmula =Somase que faz a soma daquilo tudo que for maior do que o dia 20/10/2015. Confira mais sobre ela, neste link.

Sabendo que sua sintaxe é =SOMASE(intervalo que você quer pesquisar; 'critério do que será buscado'; intervalo de soma) é só preencher a fórmula com os dados corretos no lugar certo. Assim, o intervalo a ser pesquisado é a coluna onde estão os dias (C3:C13), o critério do que será buscado será no formato sequencial de dias que aprendemos há pouco (“>42297”) e o intervalo daquilo que será somando quando o critério for encontrado será a coluna dos valores (D3:D13).

Fórmula inteira: =SOMASE(C3:C13;">42297";D3:D13)

Utilizando data como condição em uma fórmula no Excel

Agora um exemplo diferente, se quisermos somar um intervalo entre o dia 10 e o dia 15? Nesse caso precisamos de 2 condições, uma para indicar os valores acima e igual ao dia 10 e outro para os valores iguais ou menores a 15. Para isso usaremos a fórmula =SOMASES( intervalo_soma, critérios_intervalo1, critérios1, [critérios_intervalo2, critérios2], ...) usada para quando queremos comparar mais de um critério.

A fórmula utilizada foi =SOMASES(D3:D13;C3:C13;">=42290";C3:C13;"<=42293")

Utilizando data como condição em uma fórmula no Excel

Atualização: Recebemos um e-mail do leitor Diego Janjão que nos deu uma dica: Ele falou que em suas planilhas utiliza a própria data como critério, sem conversão em números. Assim temos mais uma forma de implementar as fórmulas e você pode escolher aquela que achar mais fácil. Veja um pequeno exemplo de como utilizar a dica onde, inclusive, mesclamos os 2 métodos na mesma fórmula.

Utilizando data como condição em uma fórmula no Excel

Viu como é fácil e prático? A chave do sucesso nos cálculos que utilizam data como condicional é usar o número certinho para representar as datas. Lembrando que você pode usar este tipo de formato para o cálculo e fórmula que desejar e usar data como referência.

Abaixo segue a planilha para download caso queira ver a fórmula que utilizei e fazer seus testes.

Utilizando data como condição em uma fórmula no ExcelUtilizando data como condição em uma fórmula no Excel

Problemas com o download?

Veja nosso tutorial e saiba como resolver qualquer tipo de problema que você enfrentar para baixar, abrir ou executar nossas planilhas.

Utilizando data como condição em uma fórmula no Excel

relacionados

Participe
do nosso grupo

recentes

compartilhe este post

  • ASSINE NOSSA NEWSLETTER

    As melhores publicações no
    seu e-mail

  • Preencha para confirmar