fechar

Aprender Excel

APRENDER EXCEL

DICAS E NOVIDADES SOBRE EXCEL

Usando o 'Colar Especial' do Excel

por: Maximiliano Meyer em Artigos, no dia 06/04 | 13:51 atualizado em 10/04 | 09:00

Constantemente recebo perguntas por e-mail que acabo respondendo em questões de segundos ou minutinhos. Tais perguntas são resolvidas rapidamente porque eu costumo indicar aos leitores os poderosos recursos do 'Copiar e Colar Especial', uma ferramenta completa capaz de poupar bastante trabalho.

Então abra seu Excel e vá colocando em prática tudo o que vamos ver aqui. Aposto que ela ainda vai te ajudar a resolver alguns problemas 'complicadíssimos' em questão de segundinhos, também.

O que é o Copiar e Colar Especial?

Como o nome deixa claro, ela é uma ferramenta do Excel que você pode ativar depois de copiar algum conteúdo. Você irá usá-la na hora de colar e terá diversas opções, indo muito além do simples ctrl + v.

Para copiar é a mesma coisa, a diferença é no colar que vamos utilizar o botão direito na célula de destino e ir até 'Colar Especial...' (a opção só fica 'clicável') quando você tem algo copiado.

Repare que do lado do comando tem uma flechinha. Se você colocar o mouse em cima vai poder selecionar rapidamente as opções do 'Colar especial', mas como ainda não sabemos quais são, vamos clicar em 'Colar Especial...' mesmo e ver uma por uma na janela que se abrirá.

Você pode ainda usar o atalho Ctrl + Alt + V.

Adicionei alguns valores e fórmulas aleatórias para que testássemos as opções uma a uma. Vamos lá:

Grupo Colar

Tudo: Essa daqui dispensa explicação. Quando você optar por colar 'tudo' você está usando o próprio colar normal, como se utilizasse o Ctrl + v, mas sem as formatações de estilo.

Fórmulas: Digamos que você tenha copiado a seguinte fórmula =SE(C9="";SOMA(B3:B5); MÉDIA(B3:B5)). Ao colar a mesma 3 colunas para a direita, a opção 'Fórmulas' a fórmula resultará em =SE(C9="";SOMA(B3:B5); MÉDIA(B3:B5)). Não sabe por que o Excel atualizou as referências? Então leia este artigo rapidinho

Valores: Aqui é o contrário da opção acima. Ao colar somente o valor, o Excel irá esquecer a fórmula e usar apenas o resultado que está aparecendo na célula, seja número ou texto. Não terá nenhum vínculo com a célula original.

Formatos: Digamos que uma célula está formatada como CPF e você esqueceu de ver esta aulinha e não sabe como fazer essa formatação manualmente. Use essa opção para transformar as células de destino com o mesmo formato CPF que foi copiado. Nenhum dado de fórmula e resultado irá junto. 

Comentários: Autoexplicativo, não? Quer aprender a inserir comentários? Clique aqui

Validação: Este também ignora fórmulas e valores, colando apenas a validação que foi inserida na célula de origem. Como de praxe, clique aqui para aprender sobre um dos recursos possíveis com a validação de dados do Excel. 

Na segunda coluna do grupo Colar temos as opções que copiam os temas aplicados (cores, fonte, tamanho, etc.). Se antes colássemos um valor utilizando a opção 'Valores', mesmo que a célula de origem estivesse com um fundo vermelho, teríamos somente os valores nus e crus colados. Agora não mais.

As opções desta coluna são:

Todos usando tema da origem: Cola tudo: valores, células mescladas, fórmulas, bordas, resultados, largura de coluna, etc.

Tudo exceto bordas: Autoexplicativo;

Larguras da coluna: Idem;

Fórmulas e formatos de número: Cola o formato dos números e a fórmula, mas não o resultado;

Valores e formatos de número: Quase o mesmo do anterior, mas ignora a fórmula e usa os valores;

Todos os formatos condicionais de mesclagem: Essa opção ficará visível apenas quando você tiver copiado uma célula que tenha uma formatação condicional. Neste caso ela será colada ali. Inclui a fórmula e demais cores, bordas, etc.

Grupo Operação

Este grupo contém 5 opções: as 4 operações básicas (soma, divisão, subtração e multiplicação) e a opção 'Nenhuma', que é selecionada por padrão.

As 5 opções estarão disponíveis quando você selecionar qualquer um dos seguintes tipos de 'Colar especial': Tudo, fórmulas, valores, todos usando tema de origem, Tudo exceto bordas, Larguras da coluna, Larguras da coluna, Fórmulas e formatos de número, Valores e formatos de número e Todos os formatos condicionais de mesclagem.

Funciona assim: Digamos que você tenha copiado uma célula com o valor 10. Se você usar o colar especial e selecionar a operação 'Adição' sobre uma célula com o valor 15, o resultado será 25. Fácil, certo?

Outras opções

Ignorar em branco: Como o nome já diz, cola tudo que foi copiado, exceto as células em branco. Isso já foi assunto de um outro tutorial por aqui

Transpor: Embora tenhamos uma função dedicada à tarefa, a =Transpor(), você pode usar o 'Colar especial' quando precisar de seus serviços. O que ela faz é passar os dados em uma coluna para uma linha e vice-versa. 

As opções de 'Ignorar em branco' e 'Transpor' podem ser incluídas em qualquer forma de 'Colar especial' que você selecionar.

E por fim, mas não menos importante (e eu diria que é uma das mais importantes) temos a opção 'Colar vínculo'. Ao utilizar este botão o valor da célula copiado será colado no alvo e então, sempre que você alterar a célula original, a célula vinculada irá acompanhar a mudança.

O procedimento de vínculo é feito através do caractere especial $ que você confere tudo no neste link

E caso você esteja com um tipo de arquivo diferente no seu Ctrl + C, como um endereço web ou uma imagem, poderá topar com a seguinte tel ao acionar o "Copiar e colar especial..." Nada muito complicado, apenas escolha uma das opções em tela.